Wordpress 3.5.1 ist da

wordpress-logo_grey-xlUpdate Update Update. Heute mal wieder eine aktuelle Version von Wordpress, Version 3.5.1 ist da. Das erste Update zum großen 3.5 ist ein Sicherheits- und Wartungsupdate und wird allen Betreibern von Wordpress angeraten.

Vorher aber gilt wie immer: Datenbank sichern, Verzeichnis sichern --> Updaten

Das Update wird euch im Backend angezeigt, oder ihr könnt es hier (de, tar.gz, 5,8 MB) und hier (wpde) downloaden.

Siehe auch

offizielles EntwicklerstatementÜbersicht der in 3.5.1 behobenen FehlerWordPress in 5 Minuten installierenWie führe ich ein Upgrade durch?Informationen zu den UpgradepaketenDie WordPress-Versionsnummern

Summary

From the announcement post, this maintenance release addresses 37 bugs with version 3.5, including:

  • Editor: Prevent certain HTML elements from being unexpectedly removed or modified in rare cases.
  • Media: Fix a collection of minor workflow and compatibility issues in the new media manager.
  • Networks: Suggest proper rewrite rules when creating a new network.
  • Prevent scheduled posts from being stripped of certain HTML, such as video embeds, when they are published.
  • Work around some misconfigurations that may have caused some JavaScript in the WordPress admin area to fail.
  • Suppress some warnings that could occur when a plugin misused the database or user APIs.

Additionally: Version 3.5.1 fixes a few security issues:

  • Server-side request forgery (SSRF) and remote port scanning via pingbacks. Fixed by the WordPress security team.
  • Cross-site scripting (XSS) via shortcodes and post content. Discovered by Jon Cave of the WordPress security team.
  • Cross-site scripting (XSS) in the external library Plupload. Plupload 1.5.5 was released to address this issue.

Eine vollständige Zusammenfassung aller Änderungen gibt es hier.

Kommentare angetrieben durch Disqus

So viele Abonenten dieser Website können nicht irren:


Dinge und Sachen im Fuss

XStat.de